Korjausohjeet: cdromin noutaminen epäonnistui apt-get-päivitystä ei voi käyttää uusien CD-levyjen lisäämiseen Virhe

Opi korjaamaan 'CD-levyn nouto epäonnistui. Käytä apt-cdromia, jotta APT tunnistaa tämän CD-levyn. apt-get-päivitystä ei voi käyttää uusien CD-ROM-levyjen virheen lisäämiseen.



Nykyään kokeilen peruskäyttöjärjestelmä ja tämän aikana kohtasin erikoisen päivitysvirheen: CD-levyn nouto epäonnistui. Käytä apt-cdromia, jotta APT tunnistaisi tämän CD-levyn. apt-get-päivitystä ei voi käyttää uusien CD-ROM-levyjen lisäämiseen . Koko virhe näytti tältä apt-get update -komento :

W: cdrom: // elementary OS 0.3 _Freya_-Daily amd64 (20150208)/dists/trusty/limited/binary-amd64/Packages noutaminen epäonnistui Käytä APT: n tunnistamaa CD-ROM-levyä apt-cdromin avulla. apt-get-päivitystä ei voi käyttää uusien CD-ROM-levyjen lisäämiseen

E: Joidenkin hakemistotiedostojen lataaminen epäonnistui. Ne on jätetty huomiotta tai vanhoja käytetään sen sijaan.



Tässä viestissä näytän sinulle, kuinka korjata tämä virhe.

Korjaus cdromin noutaminen epäonnistui apt-get-päivitystä ei voi käyttää uusien CD-ROM-levyjen lisäämiseen

Syynä tähän virheeseen on se, että CD-ROM on sisällytetty tähän yhdeksi lähteeksi. Tämä tarkoittaa, että järjestelmäsi yrittää etsiä ohjelmistopäivityksiä Linux -järjestelmän ISO -kuvasta tai CD -levyltä. Jos se on kytketty verkkovirtaan, se voi toimia, mutta silti se ei ole se, miten sitä pitäisi käyttää.



Ja tämän ongelman korjaamiseksi sinun on poistettava tämä ohjelmistolähteiden luettelosta.

Sisään Ubuntu , etsi Ohjelmistot ja päivitykset:

youtube-dl lataus soittolista

Nyt korjataksemme virheemme, käytämme komentorivireittiä. Avaa päätelaite ja käytä seuraavaa riviä nähdäksesi, mitä lähdeluetteloon sisältyy:

cat /etc/apt/sources.list

Tulos oli minulle seuraava:

deb cdrom: [elementary OS 0.3 _Freya_ - Daily amd64 (20150208)]/ trusty main limited
deb http://archive.ubuntu.com/ubuntu/ trusty tärkein rajoitettu universumi multiverse
deb-src http://archive.ubuntu.com/ubuntu/ trusty tärkein rajoitettu universumi multiverse
deb http://security.ubuntu.com/ubuntu/ trusty-security tärkein rajoitettu universumi multiverse
deb-src http://security.ubuntu.com/ubuntu/ trusty-security päärajoitettu universumi multiverse
deb http://archive.ubuntu.com/ubuntu/ trusty-updates tärkein rajoitettu universumi multiverse
deb-src http://archive.ubuntu.com/ubuntu/ trusty-updates päärajoitettu universumi multiverse

Katso yllä olevan luettelon ensimmäistä riviä. Se sisältää cdromin. Meidän on kommentoitava tätä riviä lisäämällä # sen eteen, jotta se näyttää tältä:

#deb cdrom: [elementary OS 0.3 _Freya_ - Daily amd64 (20150208)]/ trusty main limited

Voit tehdä tämän käyttämällä alla olevaa komentoa:

sudo gedit /etc/apt/sources.list

Kun olet muokannut sources.list-luetteloa, suorita apt-get-päivitys uudelleen. Virhe 'apt-get update ei voida käyttää uusien CD-ROM-levyjen lisäämiseen' olisi pitänyt korjata.

web -suoja pitäisi poistaa

Jos kohtaat muita päivitysongelmia, katso tämä artikkeli, joka on kokoelma eniten yleisiä Ubuntun päivitysvirheiden korjauksia .

Toivottavasti tämä opetusohjelma oli hyödyllinen. Jos sinulla on kysyttävää tai ehdotuksia, voit jättää kommentin.


Kuten lukemasi? Ole hyvä ja jaa se muiden kanssa.