Aloittelijan opas erilaisten päivitykseen liittyvien virheiden käsittelyyn Ubuntussa

Päivitysvirheet ovat yleisiä ja paljon Ubuntussa ja muissa Ubuntuun perustuvissa Linux -jakeluissa. Tässä on joitain yleisiä Ubuntun päivitysvirheitä ja niiden korjauksia.



Kuka ei ole törmännyt virheeseen päivitettäessä Ubuntussa? Päivitysvirheet ovat yleisiä ja paljon Ubuntussa ja muissa Ubuntuun perustuvissa Linux -jakeluissa. Tässä on joitain yleisiä Ubuntun päivitysvirheitä ja niiden korjauksia.

Tämä artikkeli on osa Ubuntun aloittelijasarjaa, joka selittää Ubuntun tietotaidon, jotta uusi käyttäjä voisi ymmärtää asiat paremmin.



Aiemmassa artikkelissa keskustelin kuinka päivittää Ubuntu . Tässä opetusohjelmassa keskustelen tavallisista virheistä, joita saatat kohdata päivityksen aikana Ubuntu . Se tapahtuu yleensä siksi, että yritit lisätä ohjelmistoja tai arkistoja itse ja se todennäköisesti aiheutti ongelman.

Ei ole syytä paniikkiin, jos näet virheet järjestelmän päivityksen aikana.Virheet ovat yleisiä ja korjaus on helppoa. Opit korjaamaan nämä yleiset päivitysvirheet.



Ennen kuin aloitat, suosittelen lukemaan nämä kaksi artikkelia, jotta ymmärrät paremmin Ubuntun arkiston käsitteen.

Ymmärrä Ubuntun arkistot
Ymmärrä Ubuntun arkistot

Opi mitä Ubuntun eri arkistot ovat ja miten niiden avulla voit asentaa ohjelmistoja järjestelmääsi.

Lue lisää PPA: n ymmärtäminen Ubuntussa
PPA: n ymmärtäminen Ubuntussa

Paranna edelleen käsitystäsi arkistoista ja pakettien käsittelystä Ubuntussa tämän yksityiskohtaisen PPA -oppaan avulla.

Lue lisää

Virhe 0: arkiston tietojen lataaminen epäonnistui

Monet Ubuntun työpöytäkäyttäjät päivittävät järjestelmänsä graafisen ohjelmistopäivitystyökalun avulla. Sinulle ilmoitetaan, että järjestelmääsi on saatavilla päivityksiä, ja voit napsauttaa yhtä painiketta aloittaaksesi päivitysten lataamisen ja asentamisen.

apt get install vim

No näin yleensä käy. Mutta joskus näet seuraavanlaisen virheen:

kriittinen hälytys Microsoft popup chromesta

Poista PPA ohjelmiston ja päivitysten avulla Ubuntussa

Ohjelmistoluettelosi päivitetään, kun teet sen. Jos suoritat päivityksen uudelleen, virheen ei pitäisi näkyä.

Virhe 4: Pakettitiedostojen lataaminen epäonnistui

Samanlainen virhe on pakettitiedostojen lataaminen epäonnistui kuten tämä:

ei onnistunut lataamaan pakettitiedostoja Virhe Ubuntu 14.04: ssä

Tässä tapauksessa ohjelmistosta on saatavana uudempi versio, mutta sitä ei levitetä kaikkiin peileihin. Jos et käytä peiliä, voit korjata sen helposti vaihtamalla ohjelmistolähteet pääpalvelimeksi. Lue tämä artikkeli saadaksesi lisätietoja paketin latausvirheestä.

Mene Ohjelmistot ja päivitykset ja muutti latauspalvelimen pääpalvelimeksi:

virhe ladattaessa pakettitiedostoja

Virhe 5: GPG -virhe: Seuraavia allekirjoituksia ei voitu vahvistaa

PPA: n lisääminen voi johtaa myös seuraavaan GPG -virhe: Seuraavia allekirjoituksia ei voitu vahvistaa kun yrität suorittaa päivityksen päätelaitteessa:

W: GPG error: http://repo.mate-desktop.org saucy InRelease: The following signatures couldn’t be verified because the public key is not available: NO_PUBKEY 68980A0EA10B4DE8

Sinun tarvitsee vain hakea tämä julkinen avain järjestelmästä. Hae avaimen numero viestistä. Yllä olevassa viestissä avain on 68980A0EA10B4DE8.

Tätä avainta voidaan käyttää seuraavalla tavalla:

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 68980A0EA10B4DE8

Kun avain on lisätty, suorita päivitys uudelleen ja sen pitäisi olla kunnossa.

Virhe 6: BADSIG -virhe

Toinen allekirjoitukseen liittyvä Ubuntun päivitysvirhe on BADSIG -virhe, joka näyttää tältä:

W: A error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: http://extras.ubuntu.com precise Release: The following signatures were invalid: BADSIG 16126D3A3E5C1192 Ubuntu Extras Archive Automatic Signing Key  
W: GPG error: http://ppa.launchpad.net precise Release:
The following signatures were invalid: BADSIG 4C1CBC1B69B0E2F4 Launchpad PPA for Jonathan French W: Failed to fetch http://extras.ubuntu.com/ubuntu/dists/precise/Release

Kaikki arkistot on allekirjoitettu GPG: llä, ja jostain syystä järjestelmä löytää ne virheellisiksi. Sinun on päivitettävä allekirjoitusavaimet. Helpoin tapa tehdä tämä on luoda apt -pakettiluettelo (allekirjoitusavaimillaan) ja siinä pitäisi olla oikea avain.

Käytä seuraavia komentoja yksitellen päätelaitteessa:

ei voi avata jaettua objektitiedostoa
cd /var/lib/apt sudo mv lists oldlist sudo mkdir -p lists/partial sudo apt-get clean sudo apt-get update

Virhe 7: Osittainen päivitysvirhe

Päivitysten suorittaminen terminaalissa voi aiheuttaa tämän osittaisen päivitysvirheen:

Osittainen päivitysvirhe Linuxissa
Not all updates can be installed  
Run a partial upgrade, to install as many updates as possible

Suorita seuraava komento terminaalissa korjataksesi tämän virheen:

sudo apt-get install -f

Virhe 8: lock/var/cache/apt/archives/lock ei saatu

Tämä virhe ilmenee, kun toinen ohjelma käyttää APT: tä. Oletetaan, että asennat jotain Ubuntun ohjelmistokeskukseen ja yrität samalla suorittaa apt -sovelluksen päätelaitteessa.

E: Could not get lock /var/cache/apt/archives/lock – open (11: Resource temporarily unavailable)  
E: Unable to lock directory /var/cache/apt/archives/

Tarkista, käyttääkö jokin muu ohjelma apt -ohjelmaa. Se voi olla komentoa käyttävä terminaali, Software Center, Software Updater, Software & Updates tai mikä tahansa muu sovellus, joka käsittelee sovellusten asentamista ja poistamista.

Jos voit sulkea muita tällaisia ​​ohjelmia, sulje ne. Jos prosessi on käynnissä, odota sen päättymistä.

Jos et löydä tällaisia ​​ohjelmia, käytä seuraavaa komento tappaa kaikki tällaiset käynnissä olevat prosessit :

sudo killall apt apt-get

Tämä on hankala ongelma ja jos ongelma jatkuu, lue tämä yksityiskohtainen opetusohjelma korjata, ettei hallintohakemistovirhettä voi lukita Ubuntussa .

gmail -sovellus Windows 8 -tietokoneelle

Onko sinulla muita päivitysvirheitä?

Se kokoaa luettelon usein esiintyvistä Ubuntu -päivitysvirheistä. Toivottavasti tämä auttaa sinua pääsemään eroon näistä virheistä.

Oletko törmännyt viime aikoina muuhun päivitysvirheeseen Ubuntussa, jota ei ole käsitelty täällä? Mainitse se kommenteissa ja yritän tehdä siitä nopean opetusohjelman.


Kuten lukemasi? Ole hyvä ja jaa se muiden kanssa.